Thanks for the response. To be honest, even with the provided sample, I’m not sold on the idea that the __Repo
classes made it better, mostly because the name __Repo
is not a descriptive name regarding what it is, what it does, what it’s supposed to do (it certainly doesn’t do things like “create resources that represent asynchronously loaded cached data with refresh triggers”).
It is most likely a question of naming. For example, SchedulerProvider
and BackendConnector
would be more descriptive names than SchedulerRepo
and BackendRepo
. If these items in the backend connector (ConnectionAssets, Authentication
) always belong together, you can definitely bundle them together in a class. But now you again no longer have a Repo
😉
The name Registry
could sometimes work, it’s similar and maybe that was the intention.